Issue:
When you login the AEM with the correct username/password in IE 10 (currently this issue is found to occur only with IE 10), the login page will keep the same and nothing would happen.
Cause:
You didn’t set the Compatibility View settings.
Solution:
Before you take the action below please make sure you have added the URL of the application as the Trusted Site.
Step 1: Go to IE > Tools > Compatibility View settings.
Step 2: Add your web site to be displayed in the compatibility view.
By doing so, if you get the blank screen after entering the login information, please Refresh the page.